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Abstract. In general, polymer photodegradation is an important aspect of polymer science
that is of great interest to chemistry, materials science, biology, and physics students who engage
in this field of research. Wood consists of three main polymers, which makes it a good candidate
for such photodegradation studies. Aside from structural changes based on chemical analysis,
color change assessment can also be employed to check any extent of degradation on wood
without the need for sophisticated analytical equipment. This study presents the application
of two image processing programs in color analysis of wood photodegradation: ImageJ and
Colormath library, which are Java-based and Python-based software, respectively. Images of
unexposed and UV-exposed wood samples were taken using a smartphone as an affordable
digital camera. RGB channel values from these images were analyzed and quantified by ImageJ
software. These values were converted to the corresponding CIEL*a*b* parameters using the
Colormath library to calculate the color change, ∆E. For the 3-hour exposed sample, ∆E is
equal to 4.29. This value indicates appreciable color change, according to the criteria from
literature. Regardless of the exposure time, the wood samples become darker as indicated by
the negative value in the change in lightness L*.

1. Introduction
The Covid-19 pandemic has prompted science educators and students to improvise methods and
setups in analyzing various physical phenomena. Image processing programs can be a valuable
asset to the researcher, especially for those working from home or to those who do not have access
to laboratory equipment. These programs have numerous applications, including the description
of basic topography or morphology in quantitative metallography [1]. Other applications include,
but are not limited to, the estimation of pathogen concentrations, colorimetric analysis of iron
ions in water, and the size measurements of polarized optical microscopy images [2–4]. In a
study of wood, however, image processing programs are useful in color analysis to observe any
color changes in a given wood type.

Color analysis is crucial in the determination of photodegradation in wood species. Samples
are expected to show color changes over a period of ultraviolet (UV) irradiation time [5–7]. For
some wood species, this color change is easily observed with the naked eye, while for others
it is difficult. Regardless, it is necessary to quantify the results to support the qualitative
observations. In practice, it is more common to utilize spectrophotometers in the laboratory,
which use CIEL*a*b* measurements. However, it is still possible to measure the same set of
data and analyze color changes in a work-from-home setup using image processing programs
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and a quick conversion to CIEL*a*b* measurements. [8].
ImageJ is a free, online software with multiple functions, one of which is color analysis [9].

The images can be analyzed using the average method or the weighted method depending on
the preferences, providing a set of measurements in the RGB scale [10]. Given any possible
limitations on the access to spectrophotometers, finances and the ongoing pandemic, ImageJ
is a useful alternative because it can be done at home and requires no elaborate setup [11].
This program is supplemented with the Colormath library, a Python-based library which can
convert the RGB values gathered on ImageJ into CIEL*a*b* values [12]. This will provide a
more detailed analysis on wood photodegradation.

Observing clear and obvious color changes through image processing programs is the first step
in indicating possible chemical changes in the wood structure, particularly to its main polymer
components: lignin, cellulose and hemicellulose. With the known polymorphs of cellulose, it
is cellulose I that is naturally found in wood in parallel strands in the absence of hydrogen
bonding [13]. Through chemical analysis later on, the formation of crystallized cellulose I is
expected during photodegradation [6]. This indicates the presence of reactions within the wood
samples during exposure.

Many experiments on wood photodegradation are conducted using natural sunlight. Results
are significant and substantial, although it requires longer time period that can take hundreds
of days [14, 15]. Additionally, natural weathering is heavily reliant on the weather conditions,
which are not constant and are difficult to control [16]. Artificial weathering is often used as an
alternative, wherein wood samples are exposed to a UV laser or UV lamp [17]. Compared to
natural weathering, artificial weathering can illustrate color changes immediately within the first
few hours, whereas natural weathering generally can take up to a few weeks before observable
color changes are visible [18]. While significant, the color changes observed will be supported
by further characterization of the wood samples through chemical analysis in Attenuated Total
Reflection Fourier Transform Infrared (ATR-FTIR) Spectroscopy.

2. Methodology
Shorea polysperma, commonly known as Tanguile or Tangile, wood samples were cut to a
dimension of 6 cm x 6 cm x 1 cm in length, width, and thickness respectively. Afterwards,
the edges and sides were smoothened with sandpaper to remove any blisters. The samples were
then placed in a clean box to cover it from premature, natural and artificial weathering. The
box was covered with a lid and stored in a space away from heat and light.

The wood samples were exposed to a 100-Watt UV germicidal lamp, as depicted in figures
1 and 2, having a quartz tube with peak emission wavelength at 254 nm [19]. Wood samples
were exposed at a position 18cm away from the UV lamp tube. The exposure was done at three
different time intervals (1, 2, and 3 hours). The samples were placed on a stationary placeholder
such that the faces were perpendicular to the beam of UV light. To maintain control of the
experiment, artificial photodegradation was conducted at the same time period, from 1:00 to
5:00 PM. No experiments were done during rainy days, both during and before the designated
experiment time period. Before and after use, samples were placed in non-transparent plastic
containers, to avoid any premature natural and artificial degradation.

A representative UV exposed-sample per batch was chosen consistently for image analysis, on
the basis of its proximity relative to the center of the lamp. Before and after exposure, images
of the samples were taken using a smartphone as an affordable digital camera. It is important
to maintain the same setup for image capture before using the images in ImageJ analysis. In a
home setup, as shown in figure 3, a tripod was used for stability and extended using a monopod
so that it can clamp the camera in place and extend it directly above the sample. A flat surface
is recommended to avoid any movement from the sample. Additionally, the background color
for image capture should not be similar to the sample. Unless the sample in question is the color
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Figure 1. Diagram of the UV photodegra-
dation setup for the wood samples.

Figure 2. Actual placement of samples
during testing. The top lid was removed for
picture-taking.

white, a regular A4 sheet of paper may be used as the background. Image capture was taken
on a mobile phone, using High Dynamic Range (HDR) and no flash. The room lighting was
consistent such that a white LED light illuminated the sample from above. Care was taken to
remove or cover any possible disturbances to the image capture. Only one image of each sample
was necessary before proceeding to image processing.

Figure 3. Phone capture setup for wood samples.

Color analysis was first done on ImageJ software. Opening this software will display the
ImageJ console. To analyze a picture of interest, go to File > Open, as depicted in figure 4.

After selecting the picture from a file, the picture will be opened as a new window on ImageJ,
as in figure 5. An image was split into RGB channels through Image > Color > Split Channels
as depicted in figure 6. Three different color images of the wood sample were shown in figures
7.

The macro option was used to ensure that the measurement is taken in the same area. This
is done by going to Plugins > Macros > Record, given in figure 8. When the Recorder window
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Figure 4. The ImageJ console appearance.
Figure 5. The file appearance as it is opened
on the software.

Figure 6. Process to split to the color
channels.

Figure 7. Resulting split channels for the
wood sample.

opens, select the rectangle tool from the toolbar, which is the leftmost option on the console.
By default, the rectangle tool is already selected when you open ImageJ. The rectangle formed
on the sample will be the area of analysis for ImageJ.

A rectangle was traced over the middle portion of the wood sample using the rectangle tool.
This was recorded on the Recorder window with the coordinates of the rectangle corners, as
depicted in figure 9.

To measure the color brightness of this particular area, press M on the keyboard. This will run
the measure function on the Recorder. A new Results window will appear displaying the results
of the rectangle area, as well as the mean, minimum and maximum brightness measurement
inside the rectangle, like in figure 10.

To officially make the macro, click Create on the Recorder window. A new macro window
will appear on the screen, as in figure 11. Save this macro with File > Save As, like in figure
12. The macro will be renamed to the chosen File name. The macro is officially made and you
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Figure 8. The process for making macros.
Figure 9. The mechanism for the rectangle
measurement.

Figure 10. The color measurement for the image on ImageJ.

can close the Recorder window.
To recall the macro and subsequently get the brightness for the other color channels, go to

Plugins > Macros > Run, and then select the saved macro, as in figure 13. The software will
draw the rectangle in the same position according to the exact coordinates and get the brightness
measurements in the same Results window. Once all measurements are taken from the samples,
the data can be saved with File > Save As, or copied and pasted onto data processing software,
like Microsoft Excel.

The measurements on ImageJ are done in the RGB scale. However, most data reported in
the literature for wood photodegradation is done in the CIEL*a*b* system [14]. To convert the
RGB measurements into CIEL*a*b*, we can use the Python Colormath library [20]. For this
program, Spyder with Python 3.8 was used, although it is possible to do the conversion on other
python integrated development environments (IDEs). On the console, import sRGBColor and
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Figure 11. Recorder feature on ImageJ. Figure 12. Saving the macro on ImageJ.

Figure 13. Running a macro on ImageJ.

LabColor from Color Objects and convert color from Color Conversions. Insert your RGB color
values inside the sRGBColor function. Do note that the conversion is done with the RGB values
scaled from 0 to 1. To do this, simply divide the RGB values by 255.

Convert your RGB values to L*a*b* values with the convert color function [20]. The
parameters are the original color system, and the system you want to convert into. For the
CIEL*a*b* system, there are two extra parameters concerning the observer and illuminant. For
this conversion, the 10 degree observer was used, along with the D65 illuminant. The white point
D65 is an estimation of the white color produced by mid-day sunlight [21]. These specifications
are in line with reported literature on photodegradation of wood [22]. To get your converted
values, simply use the print function. The values will be displayed on the console, like in figure
14.

3. Results and Discussion
By qualitative observation with the naked eye, it can be rather difficult to observe any obvious
color changes like in figure 15 depending on the type of wood, which makes quantitative color
analysis necessary.
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Figure 14. Color conversion using the Python Colormath library.

Figure 15. Tanguile wood before and after exposure to UV light.

Table 1 shows the mean RGB channel values similar to the one depicted in figure 10, and the
corresponding CIEL*a*b* parameters obtained from the color conversion console in figure 14.
As shown in table 1, Tanguile wood samples displayed a decrease in the lightness values, L*,
regardless of the exposure time, meaning the samples got darker overall [23]. This is in contrast
with the varying changes across the green-red axis, a* , which had samples that turned more
red, while others became less red [7]. The results for the blue-yellow axis, b*, were slightly more
consistent, displaying a decrease in the b* value for 1 and 2 hours of exposure and turned less
yellow [24]. However, by the 3 hour exposure time, b* increased, which implies that the sample
turned more yellow.

Using the converted CIEL*a*b* measurements in table 1, it is possible to get the overall color
change, ∆E, given by the square of the differences between two values as indicated in equation
(1). This is in accordance to the ISO 11664-6 (2014) standard, which takes the color change
between exposed and unexposed samples for all CIEL*a*b* measurements [25]. The parameters
L∗
1, a

∗
1, and b∗1 refer to the CIEL*a*b* measurements before artificial weathering while L∗

2, a
∗
2,

and b∗2 refer to the measurements after artificial weathering. Using equation (1) yielded a value
of a maximum of 4.29 after three hours displayed in table 2, which, according to the literature,
represents appreciable color change [25]. This is further represented by figure 16, which appears
to show a linear increase in the overall color change after three hours. Even at three hours
of UV exposure, UV light already has an effect on wood. For future experiments it would be
interesting to observe the effects on wood beyond three hours to have a greater understanding
on the degree of photodegradation on the wood samples.
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Table 1. Mean RGB channel values and converted CIEL*a*b* measurements for samples of
Tanguile wood exposed to UV for 1, 2, and 3 hours.

Time R G B L* a* b*

1 hr Before 130.41 87.207 45.605 40.94 13.53 30.96
After 125.469 83.48 42.292 39.30 13.23 30.71

2 hr Before 138.102 94.978 50.764 44.00 12.86 31.93
After 132.129 88.932 47.635 41.64 13.45 30.70

3 hr Before 141.789 97.671 52.58 45.18 13.10 32.44
After 131.104 87.05 42.283 40.95 13.71 32.80

∆E =
√
(L∗

2 − L∗
1)

2 + (a∗2 − a∗1)
2 + (b∗2 − b∗1) (1)

Table 2. Calculated values for ∆L*, ∆a*, ∆b*, and ∆E at different exposure times for Tanguile
wood samples.

Time ∆L* ∆a* ∆b* ∆E

1 hr −1.64 −0.30 −0.25 1.69
2 hr −2.36 0.59 −1.23 2.73
3 hr −4.23 0.61 0.36 4.29

Although chemical analysis is beyond the scope of this paper, it is noteworthy that the
color analysis measurements were supported by the decrease in the absorbance (A) ratio at
A1340/A1320 during ATR-FTIR spectroscopy in table 3, where A1340/A1320 denotes the
absorbance at 1340 cm-1 wavenumber divided by the absorbance at 1320 cm-1. (A1340/A1320)0
denotes the ratio before artificial weathering, while (A1340/A1320)t denotes the ratio for
both wavenumbers after artificial weathering. Colom, Carrillo, Nogués, and Garriga used the
absorbance (A) ratio between 1335 cm-1 and 1316 cm-1, but for this study the closest set of
data for the Tanguile wood were at the 1340 cm-1 and 1320 cm-1 [6]. The decrease in ratio
infers that there is increased cellulose I content of the wood that evolves and crystallizes [6].
This then supports the idea that reactions are taking place within the wood samples during
photodegradation.

4. Summary and Conclusion
In the absence of a spectrophotometer, the use of image processing programs in color analysis
can be a reliable alternative to probe wood photodegradation. As shown in this study, color
analysis was successfully conducted using ImageJ and Colormath library software for a simple,
work-from-home setup. Regardless of the exposure time, the wood samples become darker as
indicated by the negative value in the change in lightness L*. Our data show a linear increase in
the overall color change ∆E as a function of UV exposure time from one to three hours. After
three hours of exposure, the maximum ∆E value of 4.29 indicates appreciable color change,
according to the criteria from literature. This suggests photodegradation in the wood samples
and can be supported in later characterization under ATR-FTIR spectroscopy.
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Table 3. Absorbance (A) ratios for 1340 cm-1 and 1320 cm-1 wavenumbers of the Tanguile
wood samples exposed in UV for three hours.

Ratio Value

(A1340/A1320)0 0.978

(A1340/A1320)t 0.567

Figure 16. Overall color change as a function of exposure time for Tanguile samples during
UV photodegradation.
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[11] Abràmoff M D, Magalhães P J and Ram S J 2004 Biophotonics international 11 36–42
[12] Schregle R and Wittkopf S 2018 Buildings 8 30
[13] Nunes R C R 2017 Rubber nanocomposites with nanocellulose Progress in rubber nanocomposites (Elsevier)

pp 463–494
[14] Arpaci S S, Tomak E D, Ermeydan M A and Yildirim I 2021 Polymer Degradation and Stability 183 109415
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